KORE Case CS0236589 - Service Degradation - OmniSIM US - 2025-09-09

Incident Report for Butlr

Postmortem

Only impacted newly registered users. No impact to Butlr.

Posted Sep 11, 2025 - 02:13 UTC

Resolved

Impacted Services: Provisioning

Impacted Services: Network registration, data, SMS and voice

When
Start: Tuesday, September 09, 2025 17:00 UTC / Tuesday, September 09, 2025 13:00 EDT (UTC-4)
End: Wednesday, September 10, 2025 15:22 UTC / Wednesday, September 10, 2025 11:22 EDT (UTC-4)

What
Description: An issue might be preventing newly activated OmniSIM US from registering to networks has been detected and is being investigated. We strongly recommend not to activate new OmniSIM US physical SIMs or OmniSIM US profiles until the investigation is complete. Further updates will be shared as they become available.

Resolution: Our engineering team worked closely with our vendor to identify and resolve an issue that may have prevented newly activated OmniSIM US and Reach SIMs from connecting to mobile networks. The service degradation is now resolved.
Posted Sep 10, 2025 - 00:00 UTC